Skip to content

← Actionable
High, CVSS 8.1

Webkit PDFs for TYPO3 has SQL Injection vulnerability

CVE-2010-4961GHSA-9568-hcj9-rf7v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dmk/webkitpdf 1.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2010-4961: 1.08% estimated exploitation activity in the next 30 days; percentile 65.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

SQL injection vulnerability in the Webkit PDFs (webkitpdf) extension before 1.1.4 for TYPO3 allows remote attackers to execute arbitrary SQL commands via unspecified vectors.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9568-hcj9-rf7v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2010-4961

Advisory: Webkit PDFs for TYPO3 has SQL Injection vulnerability
IDs: CVE-2010-4961, GHSA-9568-hcj9-rf7v
Record: https://patchnext.com/advisories/cve-2010-4961 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dmk/webkitpdf 1.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist dmk/webkitpdf: affected < 1.1.4; fixed in 1.1.4

## Suggested inspection (read-only)
- Packagist dmk/webkitpdf: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dmk/webkitpdf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9568-hcj9-rf7v (GitHub-reviewed advisory GHSA-9568-hcj9-rf7v lists affected ranges: Packagist dmk/webkitpdf >=0 <1.1.4)

Commands are suggestions: review each one before running it.

Loading voting…