DOMPDF Remote File Inclusion Vulnerability
CVE-2010-4879GHSA-48r9-4v93-x4wh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dompdf/dompdf 0.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist dompdf/dompdf
- Affected
- >= 0.6, < 0.6.1
- Fixed in
- 0.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-48r9-4v93-x4wh lists affected ranges: Packagist dompdf/dompdf >=0.6 <0.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2010-4879: 5.23% estimated exploitation activity in the next 30 days; percentile 92.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PHP remote file inclusion vulnerability in dompdf.php in dompdf 0.6.0 beta1 allows remote attackers to execute arbitrary PHP code via a URL in the inputfile parameter.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-48r9-4v93-x4wh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-4879 Advisory: DOMPDF Remote File Inclusion Vulnerability IDs: CVE-2010-4879, GHSA-48r9-4v93-x4wh Record: https://patchnext.com/advisories/cve-2010-4879 (revision 1, source checked 26 Oct 2026, 14:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dompdf/dompdf 0.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist dompdf/dompdf: affected >= 0.6, < 0.6.1; fixed in 0.6.1 ## Suggested inspection (read-only) - Packagist dompdf/dompdf: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dompdf/dompdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-48r9-4v93-x4wh (GitHub-reviewed advisory GHSA-48r9-4v93-x4wh lists affected ranges: Packagist dompdf/dompdf >=0.6 <0.6.1) Commands are suggestions: review each one before running it.
Loading voting…