ImpressCMS Cross-site Scripting vulnerability via quicksearch_ContentContent parameter
CVE-2010-4616GHSA-39vm-rvwh-q86j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (impresscms/impresscms 1.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist impresscms/impresscms
- Affected
- < 1.2.4
- Fixed in
- 1.2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-39vm-rvwh-q86j lists affected ranges: Packagist impresscms/impresscms >=0 <1.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2010-4616: 1.08% estimated exploitation activity in the next 30 days; percentile 65.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in modules/content/admin/content.php in ImpressCMS 1.2.3 Final, and possibly other versions before 1.2.4, allows remote attackers to inject arbitrary web script or HTML via the quicksearchContentContent parameter.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-39vm-rvwh-q86j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-4616 Advisory: ImpressCMS Cross-site Scripting vulnerability via quicksearch_ContentContent parameter IDs: CVE-2010-4616, GHSA-39vm-rvwh-q86j Record: https://patchnext.com/advisories/cve-2010-4616 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: impresscms/impresscms 1.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist impresscms/impresscms: affected < 1.2.4; fixed in 1.2.4 ## Suggested inspection (read-only) - Packagist impresscms/impresscms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on impresscms/impresscms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-39vm-rvwh-q86j (GitHub-reviewed advisory GHSA-39vm-rvwh-q86j lists affected ranges: Packagist impresscms/impresscms >=0 <1.2.4) Commands are suggestions: review each one before running it.
Loading voting…