ocrodjvu is vulnerable to Arbitrary File Modification via symlink attack
CVE-2010-4338GHSA-5pjj-7m4p-wfh2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ocrodjvu 0.4.6.post2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ocrodjvu
- Affected
- >= 0.4.6.post1, <= 0.4.6.post1
- Fixed in
- 0.4.6.post2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5pjj-7m4p-wfh2 lists affected ranges: PyPI ocrodjvu >=0.4.6.post1 <=0.4.6.post1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2010-4338: 0.32% estimated exploitation activity in the next 30 days; percentile 24.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
ocrodjvu 0.4.6-1 on Debian GNU/Linux allows local users to modify arbitrary files via a symlink attack on temporary files that are generated when Cuneiform is invoked as the OCR engine.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5pjj-7m4p-wfh2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-4338 Advisory: ocrodjvu is vulnerable to Arbitrary File Modification via symlink attack IDs: CVE-2010-4338, GHSA-5pjj-7m4p-wfh2 Record: https://patchnext.com/advisories/cve-2010-4338 (revision 1, source checked 26 Oct 2026, 13:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ocrodjvu 0.4.6.post2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ocrodjvu: affected >= 0.4.6.post1, <= 0.4.6.post1; fixed in 0.4.6.post2 ## Suggested inspection (read-only) - `python -m pip show ocrodjvu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ocrodjvu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5pjj-7m4p-wfh2 (GitHub-reviewed advisory GHSA-5pjj-7m4p-wfh2 lists affected ranges: PyPI ocrodjvu >=0.4.6.post1 <=0.4.6.post1) Commands are suggestions: review each one before running it.
Loading voting…