Skip to content

← Actionable
Unrated

CakePHP allows remote attackers to modify internal Cake cache and execute arbitrary code

CVE-2010-4335GHSA-g2vx-8v47-4vhh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 1.3.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2010-4335: 55.20% estimated exploitation activity in the next 30 days; percentile 99.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The validatePost function in libs/controller/components/security.php in CakePHP 1.3.x through 1.3.5 and 1.2.8 allows remote attackers to modify the internal Cake cache and execute arbitrary code via a crafted data[Token][fields] value that is processed by the unserialize function, as demonstrated by modifying the filemap cache to execute arbitrary local files.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g2vx-8v47-4vhh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2010-4335

Advisory: CakePHP allows remote attackers to modify internal Cake cache and execute arbitrary code
IDs: CVE-2010-4335, GHSA-g2vx-8v47-4vhh
Record: https://patchnext.com/advisories/cve-2010-4335 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 1.3.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/cakephp: affected >= 1.2.8, < 1.3.6; fixed in 1.3.6

## Suggested inspection (read-only)
- Packagist cakephp/cakephp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/cakephp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g2vx-8v47-4vhh (GitHub-reviewed advisory GHSA-g2vx-8v47-4vhh lists affected ranges: Packagist cakephp/cakephp >=1.2.8 <1.3.6)

Commands are suggestions: review each one before running it.

Loading voting…