Skip to content

← Actionable
Unrated

Improper Limitation of a Pathname to a Restricted Directory in Apache Tomcat

CVE-2010-3718GHSA-fj6c-prgj-gr3r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 7.0.4, 6.0.30, 5.5.30), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat

    Affected
    >= 7.0.0, < 7.0.4>= 6.0.0, < 6.0.30>= 5.5.0, < 5.5.30
    Fixed in
    5.5.30, 6.0.30, 7.0.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2010-3718: 1.30% estimated exploitation activity in the next 30 days; percentile 70.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Tomcat 7.0.0 through 7.0.3, 6.0.x, and 5.5.x, when running within a SecurityManager, does not make the ServletContext attribute read-only, which allows local web applications to read or write files outside of the intended working directory, as demonstrated using a directory traversal attack.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fj6c-prgj-gr3r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2010-3718

Advisory: Improper Limitation of a Pathname to a Restricted Directory in Apache Tomcat
IDs: CVE-2010-3718, GHSA-fj6c-prgj-gr3r
Record: https://patchnext.com/advisories/cve-2010-3718 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 7.0.4, 6.0.30, 5.5.30. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat: affected >= 7.0.0, < 7.0.4; >= 6.0.0, < 6.0.30; >= 5.5.0, < 5.5.30; fixed in 5.5.30, 6.0.30, 7.0.4

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fj6c-prgj-gr3r (GitHub-reviewed advisory GHSA-fj6c-prgj-gr3r lists affected ranges: Maven org.apache.tomcat:tomcat >=7.0.0 =6.0.0 =5.5.0 <5.5.30)

Commands are suggestions: review each one before running it.

Loading voting…