TYPO3 is vulnerable to Insecure randomness in uniqid function
CVE-2010-3666GHSA-c7xr-736p-29j3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-install 4.4.1, 4.3.4, 4.2.13, 4.1.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms-install
- Affected
- < 4.1.14>= 4.2.0, < 4.2.13>= 4.3.0, < 4.3.4>= 4.4.0, < 4.4.1
- Fixed in
- 4.4.1, 4.3.4, 4.2.13, 4.1.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c7xr-736p-29j3 lists affected ranges: Packagist typo3/cms-install >=0 =4.2.0 =4.3.0 =4.4.0 <4.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2010-3666: 1.20% estimated exploitation activity in the next 30 days; percentile 68.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 contains insecure randomness in the uniqid function.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c7xr-736p-29j3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-3666 Advisory: TYPO3 is vulnerable to Insecure randomness in uniqid function IDs: CVE-2010-3666, GHSA-c7xr-736p-29j3 Record: https://patchnext.com/advisories/cve-2010-3666 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: typo3/cms-install 4.4.1, 4.3.4, 4.2.13, 4.1.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms-install: affected < 4.1.14; >= 4.2.0, < 4.2.13; >= 4.3.0, < 4.3.4; >= 4.4.0, < 4.4.1; fixed in 4.4.1, 4.3.4, 4.2.13, 4.1.14 ## Suggested inspection (read-only) - Packagist typo3/cms-install: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms-install. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c7xr-736p-29j3 (GitHub-reviewed advisory GHSA-c7xr-736p-29j3 lists affected ranges: Packagist typo3/cms-install >=0 =4.2.0 =4.3.0 =4.4.0 <4.4.1) Commands are suggestions: review each one before running it.
Loading voting…