powermail extension for TYPO3 vulnerable to SQL Injection
CVE-2010-3604GHSA-rp53-fw29-rxg3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (in2code/powermail 1.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist in2code/powermail
- Affected
- < 1.5.4
- Fixed in
- 1.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rp53-fw29-rxg3 lists affected ranges: Packagist in2code/powermail >=0 <1.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2010-3604: 1.05% estimated exploitation activity in the next 30 days; percentile 64.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
SQL injection vulnerability in the powermail extension 1.5.3 and earlier for TYPO3 allows remote attackers to execute arbitrary SQL commands via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rp53-fw29-rxg3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-3604 Advisory: powermail extension for TYPO3 vulnerable to SQL Injection IDs: CVE-2010-3604, GHSA-rp53-fw29-rxg3 Record: https://patchnext.com/advisories/cve-2010-3604 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: in2code/powermail 1.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist in2code/powermail: affected < 1.5.4; fixed in 1.5.4 ## Suggested inspection (read-only) - Packagist in2code/powermail: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on in2code/powermail. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rp53-fw29-rxg3 (GitHub-reviewed advisory GHSA-rp53-fw29-rxg3 lists affected ranges: Packagist in2code/powermail >=0 <1.5.4) Commands are suggestions: review each one before running it.
Loading voting…