Zope Object Database Denial of Service vulnerability
CVE-2010-3495GHSA-j6m4-frxh-p4x8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zodb3 3.10.0a2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zodb3
- Affected
- < 3.10.0a2
- Fixed in
- 3.10.0a2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j6m4-frxh-p4x8 lists affected ranges: PyPI zodb3 >=0 <3.10.0a2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j6m4-frxh-p4x8 lists affected ranges: PyPI zodb3 >=0 <3.10.0a2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2010-3495: 1.35% estimated exploitation activity in the next 30 days; percentile 71.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Race condition in ZEO/StorageServer.py in Zope Object Database (ZODB) before 3.10.0a2 allows remote attackers to cause a denial of service (daemon outage) by establishing and then immediately closing a TCP connection, leading to the accept function having an unexpected return value of None, an unexpected value of None for the address, or an ECONNABORTED, EAGAIN, or EWOULDBLOCK error, a related issue to CVE-2010-3492.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-j6m4-frxh-p4x8
- Revision 1 · created ·
Published from osv record GHSA-j6m4-frxh-p4x8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-3495 Advisory: Zope Object Database Denial of Service vulnerability IDs: CVE-2010-3495, GHSA-j6m4-frxh-p4x8 Record: https://patchnext.com/advisories/cve-2010-3495 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zodb3 3.10.0a2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zodb3: affected < 3.10.0a2; fixed in 3.10.0a2 ## Suggested inspection (read-only) - `python -m pip show zodb3`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zodb3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j6m4-frxh-p4x8 (OSV record GHSA-j6m4-frxh-p4x8 lists affected ranges: PyPI zodb3 >=0 <3.10.0a2 (fixed)) - Verified: https://github.com/advisories/GHSA-j6m4-frxh-p4x8 (GitHub-reviewed advisory GHSA-j6m4-frxh-p4x8 lists affected ranges: PyPI zodb3 >=0 <3.10.0a2) Commands are suggestions: review each one before running it.
Loading voting…