EGroupware Code Injection vulnerability
CVE-2010-3313GHSA-5gx6-f2qq-475f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (egroupware/egroupware 9.2.20100309, 9.1.20100309, 1.6.003), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist egroupware/egroupware
- Affected
- < 1.6.003>= 9.1, < 9.1.20100309>= 9.2, < 9.2.20100309
- Fixed in
- 9.2.20100309, 1.6.003, 9.1.20100309
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5gx6-f2qq-475f lists affected ranges: Packagist egroupware/egroupware >=0 =9.1 =9.2 <9.2.20100309
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2010-3313: 8.50% estimated exploitation activity in the next 30 days; percentile 95.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
phpgwapi/js/fckeditor/editor/dialog/fckspellerpages/spellerpages/serverscripts/spellchecker.php in EGroupware 1.4.001+.002; 1.6.001+.002 and possibly other versions before 1.6.003; and EPL 9.1 before 9.1.20100309 and 9.2 before 9.2.20100309; allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) aspellpath or (2) spellcheckerlang parameters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5gx6-f2qq-475f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-3313 Advisory: EGroupware Code Injection vulnerability IDs: CVE-2010-3313, GHSA-5gx6-f2qq-475f Record: https://patchnext.com/advisories/cve-2010-3313 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: egroupware/egroupware 9.2.20100309, 9.1.20100309, 1.6.003. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist egroupware/egroupware: affected < 1.6.003; >= 9.1, < 9.1.20100309; >= 9.2, < 9.2.20100309; fixed in 9.2.20100309, 1.6.003, 9.1.20100309 ## Suggested inspection (read-only) - Packagist egroupware/egroupware: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on egroupware/egroupware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5gx6-f2qq-475f (GitHub-reviewed advisory GHSA-5gx6-f2qq-475f lists affected ranges: Packagist egroupware/egroupware >=0 =9.1 =9.2 <9.2.20100309) Commands are suggestions: review each one before running it.
Loading voting…