MoinMoin cross-site scripting (XSS) vulnerability
CVE-2010-2969GHSA-2j76-26qq-7rvv
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI moin
- Affected
- <= 1.7.3>= 1.9.0, < 1.9.3
- Fixed in
- 1.9.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2j76-26qq-7rvv lists affected ranges: PyPI moin >=0 =1.9.0 <1.9.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2j76-26qq-7rvv lists affected ranges: PyPI moin >=0 =1.9.0 <1.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2010-2969: 2.55% estimated exploitation activity in the next 30 days; percentile 85.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site scripting (XSS) vulnerabilities in MoinMoin 1.7.3 and earlier, and 1.9.x before 1.9.3, allow remote attackers to inject arbitrary web script or HTML via crafted content, related to (1) action/LikePages.py, (2) action/chart.py, and (3) action/userprofile.py, a similar issue to CVE-2010-2487.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2j76-26qq-7rvv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2j76-26qq-7rvv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-2969 Advisory: MoinMoin cross-site scripting (XSS) vulnerability IDs: CVE-2010-2969, GHSA-2j76-26qq-7rvv Record: https://patchnext.com/advisories/cve-2010-2969 (revision 3, source checked 26 Oct 2026, 13:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: moin 1.9.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI moin: affected <= 1.7.3; >= 1.9.0, < 1.9.3; fixed in 1.9.3 ## Suggested inspection (read-only) - `python -m pip show moin`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2j76-26qq-7rvv (OSV record GHSA-2j76-26qq-7rvv lists affected ranges: PyPI moin >=0 =1.9.0 <1.9.3 (fixed)) - Verified: https://github.com/advisories/GHSA-2j76-26qq-7rvv (GitHub-reviewed advisory GHSA-2j76-26qq-7rvv lists affected ranges: PyPI moin >=0 =1.9.0 <1.9.3) Commands are suggestions: review each one before running it.
Loading voting…