Skip to content

← Actionable
Unrated

Moodle Cross-site Scripting vulnerability in the KSES text cleaning filter

CVE-2010-2230GHSA-3gm8-32vv-q8mp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 1.9.9, 1.8.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    < 1.8.13>= 1.9.0, < 1.9.9
    Fixed in
    1.8.13, 1.9.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2010-2230: 2.23% estimated exploitation activity in the next 30 days; percentile 82.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The KSES text cleaning filter in lib/weblib.php in Moodle before 1.8.13 and 1.9.x before 1.9.9 does not properly handle vbscript URIs, which allows remote authenticated users to conduct cross-site scripting (XSS) attacks via HTML input.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3gm8-32vv-q8mp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2010-2230

Advisory: Moodle Cross-site Scripting vulnerability in the KSES text cleaning filter
IDs: CVE-2010-2230, GHSA-3gm8-32vv-q8mp
Record: https://patchnext.com/advisories/cve-2010-2230 (revision 1, source checked 26 Oct 2026, 14:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 1.9.9, 1.8.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected < 1.8.13; >= 1.9.0, < 1.9.9; fixed in 1.8.13, 1.9.9

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3gm8-32vv-q8mp (GitHub-reviewed advisory GHSA-3gm8-32vv-q8mp lists affected ranges: Packagist moodle/moodle >=0 =1.9.0 <1.9.9)

Commands are suggestions: review each one before running it.

Loading voting…