Server side object manipulation in Apache Struts
CVE-2010-1870GHSA-x5fc-pgpx-59j5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.struts:struts2-core 2.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.struts:struts2-core
- Affected
- < 2.2.1
- Fixed in
- 2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x5fc-pgpx-59j5 lists affected ranges: Maven org.apache.struts:struts2-core >=0 <2.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2010-1870: 92.02% estimated exploitation activity in the next 30 days; percentile 99.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
OGNL provides, among other features, extensive expression evaluation capabilities. This vulnerability allows a malicious user to bypass the '#'-usage protection built into the ParametersInterceptor, thus being able to manipulate server side context objects. This behavior was already addressed in S2-003, but it turned out that the resulting fix based on whitelisting acceptable parameter names closed the vulnerability only partially.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x5fc-pgpx-59j5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-1870 Advisory: Server side object manipulation in Apache Struts IDs: CVE-2010-1870, GHSA-x5fc-pgpx-59j5 Record: https://patchnext.com/advisories/cve-2010-1870 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.struts:struts2-core 2.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.struts:struts2-core: affected < 2.2.1; fixed in 2.2.1 ## Suggested inspection (read-only) - Maven org.apache.struts:struts2-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.struts:struts2-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x5fc-pgpx-59j5 (GitHub-reviewed advisory GHSA-x5fc-pgpx-59j5 lists affected ranges: Maven org.apache.struts:struts2-core >=0 <2.2.1) Commands are suggestions: review each one before running it.
Loading voting…