Moodle doesn't properly check role
CVE-2010-1617GHSA-q53j-c866-h9mw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 1.9.8, 1.8.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 1.8.0, < 1.8.12>= 1.9.0, < 1.9.8
- Fixed in
- 1.8.12, 1.9.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q53j-c866-h9mw lists affected ranges: Packagist moodle/moodle >=1.8.0 =1.9.0 <1.9.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2010-1617: 1.52% estimated exploitation activity in the next 30 days; percentile 74.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
user/view.php in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 does not properly check a role, which allows remote authenticated users to obtain the full names of other users via the course profile page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q53j-c866-h9mw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-1617 Advisory: Moodle doesn't properly check role IDs: CVE-2010-1617, GHSA-q53j-c866-h9mw Record: https://patchnext.com/advisories/cve-2010-1617 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 1.9.8, 1.8.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 1.8.0, < 1.8.12; >= 1.9.0, < 1.9.8; fixed in 1.8.12, 1.9.8 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q53j-c866-h9mw (GitHub-reviewed advisory GHSA-q53j-c866-h9mw lists affected ranges: Packagist moodle/moodle >=1.8.0 =1.9.0 <1.9.8) Commands are suggestions: review each one before running it.
Loading voting…