Skip to content

← Actionable
Low, CVSS 1.3

Moodle vulnerable to Cross-site Scripting

CVE-2010-1614GHSA-5fgv-cvr8-xg48

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 1.9.8, 1.8.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 1.8.0, < 1.8.12>= 1.9.0, < 1.9.8
    Fixed in
    1.8.12, 1.9.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
EPSS
  • CVE-2010-1614: 1.67% estimated exploitation activity in the next 30 days; percentile 76.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5fgv-cvr8-xg48

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2010-1614

Advisory: Moodle vulnerable to Cross-site Scripting
IDs: CVE-2010-1614, GHSA-5fgv-cvr8-xg48
Record: https://patchnext.com/advisories/cve-2010-1614 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 1.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 1.9.8, 1.8.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 1.8.0, < 1.8.12; >= 1.9.0, < 1.9.8; fixed in 1.8.12, 1.9.8

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5fgv-cvr8-xg48 (GitHub-reviewed advisory GHSA-5fgv-cvr8-xg48 lists affected ranges: Packagist moodle/moodle >=1.8.0 =1.9.0 <1.9.8)

Commands are suggestions: review each one before running it.

Loading voting…