Skip to content

← Actionable
Medium, CVSS 4.8amended

MoinMoin Cross-site Scripting (XSS) vulnerability

CVE-2010-0828GHSA-fc72-v54c-x9jg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moin 1.9.3, 1.8.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI moin

    Affected
    >= 1.9.0, < 1.9.3>= 1.8.0, < 1.8.8
    Fixed in
    1.8.8, 1.9.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2010-0828: 2.26% estimated exploitation activity in the next 30 days; percentile 83.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting (XSS) vulnerability in action/Despam.py in the Despam action module in MoinMoin 1.8.7 and 1.9.2 allows remote authenticated users to inject arbitrary web script or HTML by creating a page with a crafted URI.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-fc72-v54c-x9jg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-fc72-v54c-x9jg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2010-0828

Advisory: MoinMoin Cross-site Scripting (XSS) vulnerability
IDs: CVE-2010-0828, GHSA-fc72-v54c-x9jg
Record: https://patchnext.com/advisories/cve-2010-0828 (revision 3, source checked 26 Oct 2026, 13:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moin 1.9.3, 1.8.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI moin: affected >= 1.9.0, < 1.9.3; >= 1.8.0, < 1.8.8; fixed in 1.8.8, 1.9.3

## Suggested inspection (read-only)
- `python -m pip show moin`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fc72-v54c-x9jg (OSV record GHSA-fc72-v54c-x9jg lists affected ranges: PyPI moin >=1.9.0 =1.8.0 <1.8.8 (fixed))
- Verified: https://github.com/advisories/GHSA-fc72-v54c-x9jg (GitHub-reviewed advisory GHSA-fc72-v54c-x9jg lists affected ranges: PyPI moin >=1.9.0 =1.8.0 <1.8.8)

Commands are suggestions: review each one before running it.

Loading voting…