Cross-site scripting in Apache ActiveMQ
CVE-2010-0684GHSA-mxf7-pv8q-294h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-parent 5.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.activemq:activemq-parent
- Affected
- < 5.3.1
- Fixed in
- 5.3.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mxf7-pv8q-294h lists affected ranges: Maven org.apache.activemq:activemq-parent >=0 <5.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2010-0684: 4.27% estimated exploitation activity in the next 30 days; percentile 91.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in createDestination.action in Apache ActiveMQ before 5.3.1 allows remote authenticated users to inject arbitrary web script or HTML via the JMSDestination parameter in a queue action.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mxf7-pv8q-294h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2010-0684 Advisory: Cross-site scripting in Apache ActiveMQ IDs: CVE-2010-0684, GHSA-mxf7-pv8q-294h Record: https://patchnext.com/advisories/cve-2010-0684 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-parent 5.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.activemq:activemq-parent: affected < 5.3.1; fixed in 5.3.1 ## Suggested inspection (read-only) - Maven org.apache.activemq:activemq-parent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.activemq:activemq-parent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mxf7-pv8q-294h (GitHub-reviewed advisory GHSA-mxf7-pv8q-294h lists affected ranges: Maven org.apache.activemq:activemq-parent >=0 <5.3.1) Commands are suggestions: review each one before running it.
Loading voting…