Improper input validation in Mort Bay Jetty
CVE-2009-4611GHSA-6jxp-7g74-2rc3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.mortbay.jetty:jetty 7.0.2, 6.1.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.mortbay.jetty:jetty
- Affected
- >= 6.0.0, < 6.1.23>= 7.0.0, < 7.0.2
- Fixed in
- 6.1.23, 7.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6jxp-7g74-2rc3 lists affected ranges: Maven org.mortbay.jetty:jetty >=6.0.0 =7.0.0 <7.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2009-4611: 3.25% estimated exploitation activity in the next 30 days; percentile 88.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mort Bay Jetty 6.x through 6.1.22 and 7.0.0 writes backtrace data without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator, related to (1) a string value in the Age parameter to the default URI for the Cookie Dump Servlet in test-jetty-webapp/src/main/java/com/acme/CookieDump.java under cookie/, (2) an alphabetic value in the A parameter to jsp/expr.jsp, or (3) an alphabetic value in the Content-Length HTTP header to an arbitrary application.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6jxp-7g74-2rc3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-4611 Advisory: Improper input validation in Mort Bay Jetty IDs: CVE-2009-4611, GHSA-6jxp-7g74-2rc3 Record: https://patchnext.com/advisories/cve-2009-4611 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.mortbay.jetty:jetty 7.0.2, 6.1.23. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.mortbay.jetty:jetty: affected >= 6.0.0, < 6.1.23; >= 7.0.0, < 7.0.2; fixed in 6.1.23, 7.0.2 ## Suggested inspection (read-only) - Maven org.mortbay.jetty:jetty: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.mortbay.jetty:jetty. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6jxp-7g74-2rc3 (GitHub-reviewed advisory GHSA-6jxp-7g74-2rc3 lists affected ranges: Maven org.mortbay.jetty:jetty >=6.0.0 =7.0.0 <7.0.2) Commands are suggestions: review each one before running it.
Loading voting…