Use of Password Hash With Insufficient Computational Effort in Apache Derby
CVE-2009-4269GHSA-fh32-35w2-rxcc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.derby:derby 10.6.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.derby:derby
- Affected
- <= 10.5.3.01
- Fixed in
- 10.6.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fh32-35w2-rxcc lists affected ranges: Maven org.apache.derby:derby >=0 <=10.5.3.01
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2009-4269: 1.43% estimated exploitation activity in the next 30 days; percentile 72.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The password hash generation algorithm in the BUILTIN authentication functionality for Apache Derby before 10.6.1.0 performs a transformation that reduces the size of the set of inputs to SHA-1, which produces a small search space that makes it easier for local and possibly remote attackers to crack passwords by generating hash collisions, related to password substitution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fh32-35w2-rxcc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-4269 Advisory: Use of Password Hash With Insufficient Computational Effort in Apache Derby IDs: CVE-2009-4269, GHSA-fh32-35w2-rxcc Record: https://patchnext.com/advisories/cve-2009-4269 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.derby:derby 10.6.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.derby:derby: affected <= 10.5.3.01; fixed in 10.6.1.0 ## Suggested inspection (read-only) - Maven org.apache.derby:derby: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.derby:derby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fh32-35w2-rxcc (GitHub-reviewed advisory GHSA-fh32-35w2-rxcc lists affected ranges: Maven org.apache.derby:derby >=0 <=10.5.3.01) Commands are suggestions: review each one before running it.
Loading voting…