phpMyAdmin Cross-site Scripting In MySQL Table Name
CVE-2009-3696GHSA-5pvv-f8h3-gw96
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyadmin/phpmyadmin 3.2.2.1, 2.11.9.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyadmin/phpmyadmin
- Affected
- >= 2.11.0, < 2.11.9.6>= 3.0.0, < 3.2.2.1
- Fixed in
- 2.11.9.6, 3.2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5pvv-f8h3-gw96 lists affected ranges: Packagist phpmyadmin/phpmyadmin >=2.11.0 =3.0.0 <3.2.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2009-3696: 2.57% estimated exploitation activity in the next 30 days; percentile 85.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.11.x before 2.11.9.6 and 3.x before 3.2.2.1 allows remote attackers to inject arbitrary web script or HTML via a crafted name for a MySQL table.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5pvv-f8h3-gw96
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-3696 Advisory: phpMyAdmin Cross-site Scripting In MySQL Table Name IDs: CVE-2009-3696, GHSA-5pvv-f8h3-gw96 Record: https://patchnext.com/advisories/cve-2009-3696 (revision 1, source checked 26 Oct 2026, 14:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyadmin/phpmyadmin 3.2.2.1, 2.11.9.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyadmin/phpmyadmin: affected >= 2.11.0, < 2.11.9.6; >= 3.0.0, < 3.2.2.1; fixed in 2.11.9.6, 3.2.2.1 ## Suggested inspection (read-only) - Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyadmin/phpmyadmin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5pvv-f8h3-gw96 (GitHub-reviewed advisory GHSA-5pvv-f8h3-gw96 lists affected ranges: Packagist phpmyadmin/phpmyadmin >=2.11.0 =3.0.0 <3.2.2.1) Commands are suggestions: review each one before running it.
Loading voting…