Typo3 API Install Tool vulnerable to Cross-site Scripting
CVE-2009-3636GHSA-c73w-4rcj-2622
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist typo3/cms-install
- Affected
- <= 4.0.13>= 4.1.0, < 4.1.13>= 4.2.0, < 4.2.10>= 4.3alpha1, < 4.3beta2
- Fixed in
- 4.2.10, 4.1.13, 4.3beta2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c73w-4rcj-2622 lists affected ranges: Packagist typo3/cms-install >=0 =4.1.0 =4.2.0 =4.3alpha1 <4.3beta2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2009-3636: 1.96% estimated exploitation activity in the next 30 days; percentile 80.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in the Install Tool subcomponent in TYPO3 4.0.13 and earlier, 4.1.x before 4.1.13, 4.2.x before 4.2.10, and 4.3.x before 4.3beta2 allows remote attackers to inject arbitrary web script or HTML via unspecified parameters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c73w-4rcj-2622
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-3636 Advisory: Typo3 API Install Tool vulnerable to Cross-site Scripting IDs: CVE-2009-3636, GHSA-c73w-4rcj-2622 Record: https://patchnext.com/advisories/cve-2009-3636 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: typo3/cms-install 4.2.10, 4.1.13, 4.3beta2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist typo3/cms-install: affected <= 4.0.13; >= 4.1.0, < 4.1.13; >= 4.2.0, < 4.2.10; >= 4.3alpha1, < 4.3beta2; fixed in 4.2.10, 4.1.13, 4.3beta2 ## Suggested inspection (read-only) - Packagist typo3/cms-install: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on typo3/cms-install. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c73w-4rcj-2622 (GitHub-reviewed advisory GHSA-c73w-4rcj-2622 lists affected ranges: Packagist typo3/cms-install >=0 =4.1.0 =4.2.0 =4.3alpha1 <4.3beta2) Commands are suggestions: review each one before running it.
Loading voting…