Skip to content

← Actionable
Unrated

actionpack and activesupport vulnerable to information leaks

CVE-2009-3086GHSA-fg9w-g6m4-557j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (activesupport 2.3.4, 2.2.3; actionpack 2.3.4, 2.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems activesupport

    Affected
    >= 2.3.0, < 2.3.4>= 2.1.0, < 2.2.3
    Fixed in
    2.3.4, 2.2.3
  • RubyGems actionpack

    Affected
    >= 2.1.0, < 2.2.3>= 2.3.0, < 2.3.4
    Fixed in
    2.3.4, 2.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2009-3086: 2.23% estimated exploitation activity in the next 30 days; percentile 82.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A certain algorithm in Ruby on Rails 2.1.0 through 2.2.2, and 2.3.x before 2.3.4, leaks information about the complexity of message-digest signature verification in the cookie store, which might allow remote attackers to forge a digest via multiple attempts.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fg9w-g6m4-557j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2009-3086

Advisory: actionpack and activesupport vulnerable to information leaks
IDs: CVE-2009-3086, GHSA-fg9w-g6m4-557j
Record: https://patchnext.com/advisories/cve-2009-3086 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: activesupport 2.3.4, 2.2.3; actionpack 2.3.4, 2.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems activesupport: affected >= 2.3.0, < 2.3.4; >= 2.1.0, < 2.2.3; fixed in 2.3.4, 2.2.3
- RubyGems actionpack: affected >= 2.1.0, < 2.2.3; >= 2.3.0, < 2.3.4; fixed in 2.3.4, 2.2.3

## Suggested inspection (read-only)
- RubyGems activesupport: check the installed version with your package manager.
- RubyGems actionpack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on activesupport, actionpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fg9w-g6m4-557j (GitHub-reviewed advisory GHSA-fg9w-g6m4-557j lists affected ranges: RubyGems actionpack >=2.1.0 =2.3.0 =2.3.0 =2.1.0 <2.2.3)

Commands are suggestions: review each one before running it.

Loading voting…