Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in Apache Tomcat
CVE-2009-2902GHSA-8wch-9gcg-v2pr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 6.0.24, 5.5.29), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat
- Affected
- >= 5.5.0, <= 5.5.28>= 6.0.0, <= 6.0.20
- Fixed in
- 5.5.29, 6.0.24
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8wch-9gcg-v2pr lists affected ranges: Maven org.apache.tomcat:tomcat >=5.5.0 =6.0.0 <=6.0.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2009-2902: 10.74% estimated exploitation activity in the next 30 days; percentile 95.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory traversal vulnerability in Apache Tomcat 5.5.0 through 5.5.28 and 6.0.0 through 6.0.20 allows remote attackers to delete work-directory files via directory traversal sequences in a WAR filename, as demonstrated by the ...war filename.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8wch-9gcg-v2pr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-2902
Advisory: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in Apache Tomcat
IDs: CVE-2009-2902, GHSA-8wch-9gcg-v2pr
Record: https://patchnext.com/advisories/cve-2009-2902 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 6.0.24, 5.5.29. A vendor fix does not mean a deployment is fixed.
## Affected components
- Maven org.apache.tomcat:tomcat: affected >= 5.5.0, <= 5.5.28; >= 6.0.0, <= 6.0.20; fixed in 5.5.29, 6.0.24
## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-8wch-9gcg-v2pr (GitHub-reviewed advisory GHSA-8wch-9gcg-v2pr lists affected ranges: Maven org.apache.tomcat:tomcat >=5.5.0 =6.0.0 <=6.0.20)
Commands are suggestions: review each one before running it.Loading voting…