Zope Object Database (ZODB) Arbitrary files reading and deletion
CVE-2009-2701GHSA-m52m-2qpx-9j4j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zodb3 3.9.0rc2, 3.8.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zodb3
- Affected
- >= 3.8, < 3.8.3>= 3.9a0, < 3.9.0rc2
- Fixed in
- 3.9.0rc2, 3.8.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m52m-2qpx-9j4j lists affected ranges: PyPI zodb3 >=3.8 =3.9a0 <3.9.0rc2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2009-2701: 0.97% estimated exploitation activity in the next 30 days; percentile 61.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Unspecified vulnerability in the Zope Enterprise Objects (ZEO) storage-server functionality in Zope Object Database (ZODB) 3.8 before 3.8.3 and 3.9.x before 3.9.0c2, when certain ZEO database sharing and blob support are enabled, allows remote authenticated users to read or delete arbitrary files via unknown vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m52m-2qpx-9j4j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2009-2701 Advisory: Zope Object Database (ZODB) Arbitrary files reading and deletion IDs: CVE-2009-2701, GHSA-m52m-2qpx-9j4j Record: https://patchnext.com/advisories/cve-2009-2701 (revision 1, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zodb3 3.9.0rc2, 3.8.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zodb3: affected >= 3.8, < 3.8.3; >= 3.9a0, < 3.9.0rc2; fixed in 3.9.0rc2, 3.8.3 ## Suggested inspection (read-only) - `python -m pip show zodb3`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zodb3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m52m-2qpx-9j4j (GitHub-reviewed advisory GHSA-m52m-2qpx-9j4j lists affected ranges: PyPI zodb3 >=3.8 =3.9a0 <3.9.0rc2) Commands are suggestions: review each one before running it.
Loading voting…