Skip to content

← Actionable
High, CVSS 8.7

phpBB vulnerable to sensitive information disclosure

CVE-2008-6507GHSA-jw8f-q84g-r3vm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpbb/phpbb 3.0.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2008-6507: 1.10% estimated exploitation activity in the next 30 days; percentile 65.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Unspecified vulnerability in phpBB before 3.0.4 allows attackers to obtain sensitive information via unknown vectors related to the lack of password prompts for a private message that quotes a post in a password-protected forum.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jw8f-q84g-r3vm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2008-6507

Advisory: phpBB vulnerable to sensitive information disclosure
IDs: CVE-2008-6507, GHSA-jw8f-q84g-r3vm
Record: https://patchnext.com/advisories/cve-2008-6507 (revision 1, source checked 26 Oct 2026, 14:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpbb/phpbb 3.0.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpbb/phpbb: affected < 3.0.4; fixed in 3.0.4

## Suggested inspection (read-only)
- Packagist phpbb/phpbb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpbb/phpbb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jw8f-q84g-r3vm (GitHub-reviewed advisory GHSA-jw8f-q84g-r3vm lists affected ranges: Packagist phpbb/phpbb >=0 <3.0.4)

Commands are suggestions: review each one before running it.

Loading voting…