PHPMailer susceptible to arbitrary code execution
CVE-2008-5619GHSA-v5c9-mmw9-829q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmailer/phpmailer 5.2.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmailer/phpmailer
- Affected
- < 5.2.10
- Fixed in
- 5.2.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v5c9-mmw9-829q lists affected ranges: Packagist phpmailer/phpmailer >=0 <5.2.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2008-5619: 58.64% estimated exploitation activity in the next 30 days; percentile 99.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
html2text.php in Chuggnutt HTML to Text Converter, as used in PHPMailer before 5.2.10, RoundCube Webmail (roundcubemail) 0.2-1.alpha and 0.2-3.beta, Mahara, and AtMail Open 1.03, allows remote attackers to execute arbitrary code via crafted input that is processed by the pregreplace function with the eval switch.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v5c9-mmw9-829q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2008-5619 Advisory: PHPMailer susceptible to arbitrary code execution IDs: CVE-2008-5619, GHSA-v5c9-mmw9-829q Record: https://patchnext.com/advisories/cve-2008-5619 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmailer/phpmailer 5.2.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmailer/phpmailer: affected < 5.2.10; fixed in 5.2.10 ## Suggested inspection (read-only) - Packagist phpmailer/phpmailer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmailer/phpmailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v5c9-mmw9-829q (GitHub-reviewed advisory GHSA-v5c9-mmw9-829q lists affected ranges: Packagist phpmailer/phpmailer >=0 <5.2.10) Commands are suggestions: review each one before running it.
Loading voting…