Moodle vulnerable to symlink attack
CVE-2008-5153GHSA-x7r4-26m9-hmgq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 1.9.4, 1.8.8, 1.7.7, 1.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 1.9.0, < 1.9.4>= 1.8.0, < 1.8.8>= 1.7.0, < 1.7.7>= 1.6.0, < 1.6.9
- Fixed in
- 1.6.9, 1.8.8, 1.9.4, 1.7.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x7r4-26m9-hmgq lists affected ranges: Packagist moodle/moodle >=1.9.0 =1.8.0 =1.7.0 =1.6.0 <1.6.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2008-5153: 0.39% estimated exploitation activity in the next 30 days; percentile 33.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
spell-check-logic.cgi in Moodle 1.9 before 1.9.4, 1.8 before 1.8.8, 1.7 before 1.7.7 and 1.6 before 1.6.9 allows local users to overwrite arbitrary files via a symlink attack on the (1) /tmp/spell-check-debug.log, (2) /tmp/spell-check-before, or (3) /tmp/spell-check-after temporary file.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x7r4-26m9-hmgq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2008-5153 Advisory: Moodle vulnerable to symlink attack IDs: CVE-2008-5153, GHSA-x7r4-26m9-hmgq Record: https://patchnext.com/advisories/cve-2008-5153 (revision 1, source checked 26 Oct 2026, 14:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 1.9.4, 1.8.8, 1.7.7, 1.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 1.9.0, < 1.9.4; >= 1.8.0, < 1.8.8; >= 1.7.0, < 1.7.7; >= 1.6.0, < 1.6.9; fixed in 1.6.9, 1.8.8, 1.9.4, 1.7.7 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x7r4-26m9-hmgq (GitHub-reviewed advisory GHSA-x7r4-26m9-hmgq lists affected ranges: Packagist moodle/moodle >=1.9.0 =1.8.0 =1.7.0 =1.6.0 <1.6.9) Commands are suggestions: review each one before running it.
Loading voting…