Skip to content

← Actionable
Unrated

Apache Tomcat Cross-site scripting (XSS) vulnerability

CVE-2008-1232GHSA-q74x-qqhr-f8rx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 6.0.17, 5.5.27, 4.1.38), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat

    Affected
    >= 4.1.0, <= 4.1.37>= 5.5.0, <= 5.5.26>= 6.0.0, <= 6.0.16
    Fixed in
    5.5.27, 4.1.38, 6.0.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2008-1232: 75.87% estimated exploitation activity in the next 30 days; percentile 99.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting (XSS) vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via a crafted string that is used in the message argument to the HttpServletResponse.sendError method.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q74x-qqhr-f8rx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2008-1232

Advisory: Apache Tomcat Cross-site scripting (XSS) vulnerability
IDs: CVE-2008-1232, GHSA-q74x-qqhr-f8rx
Record: https://patchnext.com/advisories/cve-2008-1232 (revision 1, source checked 26 Oct 2026, 16:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 6.0.17, 5.5.27, 4.1.38. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat: affected >= 4.1.0, <= 4.1.37; >= 5.5.0, <= 5.5.26; >= 6.0.0, <= 6.0.16; fixed in 5.5.27, 4.1.38, 6.0.17

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q74x-qqhr-f8rx (GitHub-reviewed advisory GHSA-q74x-qqhr-f8rx lists affected ranges: Maven org.apache.tomcat:tomcat >=4.1.0 =5.5.0 =6.0.0 <=6.0.16)

Commands are suggestions: review each one before running it.

Loading voting…