MoinMoin Cross-site scripting (XSS) vulnerability
CVE-2008-0780GHSA-53wj-6m7w-j6mj
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI moin
- Affected
- >= 1.5, <= 1.5.8>= 1.6, < 1.6.1
- Fixed in
- 1.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-53wj-6m7w-j6mj lists affected ranges: PyPI moin >=1.5 =1.6 <1.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-53wj-6m7w-j6mj lists affected ranges: PyPI moin >=1.5 =1.6 <1.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2008-0780: 1.75% estimated exploitation activity in the next 30 days; percentile 77.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in MoinMoin 1.5.x through 1.5.8 and 1.6.x before 1.6.1 allows remote attackers to inject arbitrary web script or HTML via the login action.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-53wj-6m7w-j6mj
- Revision 1 · created ·
Published from osv record GHSA-53wj-6m7w-j6mj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2008-0780 Advisory: MoinMoin Cross-site scripting (XSS) vulnerability IDs: CVE-2008-0780, GHSA-53wj-6m7w-j6mj Record: https://patchnext.com/advisories/cve-2008-0780 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: moin 1.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI moin: affected >= 1.5, <= 1.5.8; >= 1.6, < 1.6.1; fixed in 1.6.1 ## Suggested inspection (read-only) - `python -m pip show moin`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-53wj-6m7w-j6mj (OSV record GHSA-53wj-6m7w-j6mj lists affected ranges: PyPI moin >=1.5 =1.6 <1.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-53wj-6m7w-j6mj (GitHub-reviewed advisory GHSA-53wj-6m7w-j6mj lists affected ranges: PyPI moin >=1.5 =1.6 <1.6.1) Commands are suggestions: review each one before running it.
Loading voting…