Skip to content

← Actionable
Unratedamended

FTP backend for Duplicity Discloses Passwords to Process Listing

CVE-2007-5201GHSA-wxcw-rqxc-hj85

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (duplicity 0.4.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2007-5201: 0.37% estimated exploitation activity in the next 30 days; percentile 31.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The FTP backend for Duplicity before 0.4.9 sends the password as a command line argument when calling ncftp, which might allow local users to read the password by listing the process and its arguments.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wxcw-rqxc-hj85

  2. Revision 1 · created ·

    Published from osv record GHSA-wxcw-rqxc-hj85

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2007-5201

Advisory: FTP backend for Duplicity Discloses Passwords to Process Listing
IDs: CVE-2007-5201, GHSA-wxcw-rqxc-hj85
Record: https://patchnext.com/advisories/cve-2007-5201 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: duplicity 0.4.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI duplicity: affected < 0.4.9; fixed in 0.4.9

## Suggested inspection (read-only)
- `python -m pip show duplicity`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on duplicity.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wxcw-rqxc-hj85 (OSV record GHSA-wxcw-rqxc-hj85 lists affected ranges: PyPI duplicity >=0 <0.4.9 (fixed))
- Verified: https://github.com/advisories/GHSA-wxcw-rqxc-hj85 (GitHub-reviewed advisory GHSA-wxcw-rqxc-hj85 lists affected ranges: PyPI duplicity >=0 <0.4.9)

Commands are suggestions: review each one before running it.

Loading voting…