PHPMailer Shell command injection
CVE-2007-3215GHSA-6h78-85v2-mmch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmailer/phpmailer 1.7.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmailer/phpmailer
- Affected
- < 1.7.4
- Fixed in
- 1.7.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6h78-85v2-mmch lists affected ranges: Packagist phpmailer/phpmailer >=0 <1.7.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2007-3215: 2.41% estimated exploitation activity in the next 30 days; percentile 84.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
PHPMailer before 1.7.4, when configured to use sendmail, allows remote attackers to execute arbitrary shell commands via shell metacharacters in the SendmailSend function in class.phpmailer.php. Impact Shell command injection, remotely exploitable if host application does not filter user data appropriately. Patches Fixed in 1.7.4 Workarounds Filter and validate user-supplied data before putting in the into the Sender property. References https://nvd.nist.gov/vuln/detail/CVE-2007-3215 For more information If you have any questions or comments about this advisory: Open a private issue in the PHPMailer project
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6h78-85v2-mmch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2007-3215 Advisory: PHPMailer Shell command injection IDs: CVE-2007-3215, GHSA-6h78-85v2-mmch Record: https://patchnext.com/advisories/cve-2007-3215 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmailer/phpmailer 1.7.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmailer/phpmailer: affected < 1.7.4; fixed in 1.7.4 ## Suggested inspection (read-only) - Packagist phpmailer/phpmailer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmailer/phpmailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6h78-85v2-mmch (GitHub-reviewed advisory GHSA-6h78-85v2-mmch lists affected ranges: Packagist phpmailer/phpmailer >=0 <1.7.4) Commands are suggestions: review each one before running it.
Loading voting…