Skip to content

← Actionable
Unrated

DotNetNuke Vulnerable to XSS in Pass-Through Values

CVE-2007-0660GHSA-xr96-7ccp-pg5c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dotnetnuke.core 03.02.01), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2007-0660: 1.25% estimated exploitation activity in the next 30 days; percentile 69.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting (XSS) vulnerability in the IFrame module before 03.02.01 for DotNetNuke (DNN), caused by improper validation of user-supplied input by an unspecified script. Pass through values were not getting filtered, leaving them vulnerable to XSS. A remote attacker could exploit this vulnerability using various parameters in a specially-crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xr96-7ccp-pg5c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2007-0660

Advisory: DotNetNuke Vulnerable to XSS in Pass-Through Values
IDs: CVE-2007-0660, GHSA-xr96-7ccp-pg5c
Record: https://patchnext.com/advisories/cve-2007-0660 (revision 1, source checked 26 Oct 2026, 16:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dotnetnuke.core 03.02.01. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet dotnetnuke.core: affected < 03.02.01; fixed in 03.02.01

## Suggested inspection (read-only)
- NuGet dotnetnuke.core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dotnetnuke.core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xr96-7ccp-pg5c (GitHub-reviewed advisory GHSA-xr96-7ccp-pg5c lists affected ranges: NuGet dotnetnuke.core >=0 <03.02.01)

Commands are suggestions: review each one before running it.

Loading voting…