RubyGems file overwrite vulnerability
CVE-2007-0469GHSA-95vx-q4c2-64gr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rubygems-update 0.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rubygems-update
- Affected
- < 0.9.1
- Fixed in
- 0.9.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-95vx-q4c2-64gr lists affected ranges: RubyGems rubygems-update >=0 <0.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2007-0469: 4.86% estimated exploitation activity in the next 30 days; percentile 92.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The extractfiles function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-95vx-q4c2-64gr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2007-0469 Advisory: RubyGems file overwrite vulnerability IDs: CVE-2007-0469, GHSA-95vx-q4c2-64gr Record: https://patchnext.com/advisories/cve-2007-0469 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rubygems-update 0.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rubygems-update: affected < 0.9.1; fixed in 0.9.1 ## Suggested inspection (read-only) - RubyGems rubygems-update: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rubygems-update. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-95vx-q4c2-64gr (GitHub-reviewed advisory GHSA-95vx-q4c2-64gr lists affected ranges: RubyGems rubygems-update >=0 <0.9.1) Commands are suggestions: review each one before running it.
Loading voting…