Zope allows remote attackers to read arbitrary files
CVE-2006-4684GHSA-hm8g-jxjj-gfm3
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zope2
- Affected
- >= 2.7.0, <= 2.7.9>= 2.8.0, < 2.8.9
- Fixed in
- 2.8.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hm8g-jxjj-gfm3 lists affected ranges: PyPI zope2 >=2.7.0 =2.8.0 <2.8.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hm8g-jxjj-gfm3 lists affected ranges: PyPI zope2 >=2.7.0 =2.8.0 <2.8.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2006-4684: 2.45% estimated exploitation activity in the next 30 days; percentile 84.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The docutils module in Zope (Zope2) 2.7.0 through 2.7.9 and 2.8.0 through 2.8.8 does not properly handle web pages with reStructuredText (reST) markup, which allows remote attackers to read arbitrary files via a csvtable directive, a different vulnerability than CVE-2006-3458.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hm8g-jxjj-gfm3
- Revision 1 · created ·
Published from osv record GHSA-hm8g-jxjj-gfm3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2006-4684 Advisory: Zope allows remote attackers to read arbitrary files IDs: CVE-2006-4684, GHSA-hm8g-jxjj-gfm3 Record: https://patchnext.com/advisories/cve-2006-4684 (revision 2, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: zope2 2.8.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zope2: affected >= 2.7.0, <= 2.7.9; >= 2.8.0, < 2.8.9; fixed in 2.8.9 ## Suggested inspection (read-only) - `python -m pip show zope2`: prints the installed version. Run with the environment that serves production active. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zope2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hm8g-jxjj-gfm3 (OSV record GHSA-hm8g-jxjj-gfm3 lists affected ranges: PyPI zope2 >=2.7.0 =2.8.0 <2.8.9 (fixed)) - Verified: https://github.com/advisories/GHSA-hm8g-jxjj-gfm3 (GitHub-reviewed advisory GHSA-hm8g-jxjj-gfm3 lists affected ranges: PyPI zope2 >=2.7.0 =2.8.0 <2.8.9) Commands are suggestions: review each one before running it.
Loading voting…