Skip to content

← Actionable
Medium, CVSS 6.5

Cross-site scripting (XSS) vulnerability in CakePHP

CVE-2006-4067GHSA-vc29-mvwv-wpcq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 1.1.7.3363), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist cakephp/cakephp

    Affected
    >= 1.0.1.2708, <= 1.1.6.3264
    Fixed in
    1.1.7.3363

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
EPSS
  • CVE-2006-4067: 1.21% estimated exploitation activity in the next 30 days; percentile 68.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting (XSS) vulnerability in cake/libs/error.php in CakePHP before 1.1.7.3363 allows remote attackers to inject arbitrary web script or HTML via the URL, which is reflected back in a 404 (\"Not Found\") error page. NOTE: some of these details are obtained from third party information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vc29-mvwv-wpcq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2006-4067

Advisory: Cross-site scripting (XSS) vulnerability in CakePHP
IDs: CVE-2006-4067, GHSA-vc29-mvwv-wpcq
Record: https://patchnext.com/advisories/cve-2006-4067 (revision 1, source checked 26 Oct 2026, 14:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 1.1.7.3363. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/cakephp: affected >= 1.0.1.2708, <= 1.1.6.3264; fixed in 1.1.7.3363

## Suggested inspection (read-only)
- Packagist cakephp/cakephp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/cakephp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vc29-mvwv-wpcq (GitHub-reviewed advisory GHSA-vc29-mvwv-wpcq lists affected ranges: Packagist cakephp/cakephp >=1.0.1.2708 <=1.1.6.3264)

Commands are suggestions: review each one before running it.

Loading voting…