Skip to content

← Actionable
Unrated

phpSysInfo allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence

CVE-2006-3360GHSA-2wxv-3g4v-p76p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpsysinfo/phpsysinfo 3.2.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2006-3360: 5.57% estimated exploitation activity in the next 30 days; percentile 92.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Directory traversal vulnerability in index.php in phpSysInfo prior to 3.2.5 allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence and a trailing null (%00) byte in the lng parameter, which will display a different error message if the file exists.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2wxv-3g4v-p76p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2006-3360

Advisory: phpSysInfo allows remote attackers to determine the existence of arbitrary files via a .. (dot dot) sequence
IDs: CVE-2006-3360, GHSA-2wxv-3g4v-p76p
Record: https://patchnext.com/advisories/cve-2006-3360 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpsysinfo/phpsysinfo 3.2.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpsysinfo/phpsysinfo: affected < 3.2.5; fixed in 3.2.5

## Suggested inspection (read-only)
- Packagist phpsysinfo/phpsysinfo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpsysinfo/phpsysinfo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2wxv-3g4v-p76p (GitHub-reviewed advisory GHSA-2wxv-3g4v-p76p lists affected ranges: Packagist phpsysinfo/phpsysinfo >=0 <3.2.5)

Commands are suggestions: review each one before running it.

Loading voting…