Apache Derby exposes user and password attributes
CVE-2005-4849GHSA-rp7r-79rm-2758
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.derby:derby 10.1.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.derby:derby
- Affected
- <= 10.1.1.0
- Fixed in
- 10.1.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rp7r-79rm-2758 lists affected ranges: Maven org.apache.derby:derby >=0 <=10.1.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2005-4849: 2.45% estimated exploitation activity in the next 30 days; percentile 84.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Derby before 10.1.2.1 exposes the (1) user and (2) password attributes in cleartext via (a) the RDBNAM parameter of the ACCSEC command and (b) the output of the DatabaseMetaData.getURL function, which allows context-dependent attackers to obtain sensitive information.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rp7r-79rm-2758
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2005-4849 Advisory: Apache Derby exposes user and password attributes IDs: CVE-2005-4849, GHSA-rp7r-79rm-2758 Record: https://patchnext.com/advisories/cve-2005-4849 (revision 1, source checked 26 Oct 2026, 16:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.derby:derby 10.1.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.derby:derby: affected <= 10.1.1.0; fixed in 10.1.2.1 ## Suggested inspection (read-only) - Maven org.apache.derby:derby: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.derby:derby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rp7r-79rm-2758 (GitHub-reviewed advisory GHSA-rp7r-79rm-2758 lists affected ranges: Maven org.apache.derby:derby >=0 <=10.1.1.0) Commands are suggestions: review each one before running it.
Loading voting…