Roundup Directory traversal vulnerability
CVE-2004-1444GHSA-q7mf-hp9m-cx6f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (roundup 0.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI roundup
- Affected
- <= 0.6.4
- Fixed in
- 0.7.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q7mf-hp9m-cx6f lists affected ranges: PyPI roundup >=0 <0.7.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q7mf-hp9m-cx6f lists affected ranges: PyPI roundup >=0 <=0.6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2004-1444: 8.87% estimated exploitation activity in the next 30 days; percentile 95.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Directory traversal vulnerability in Roundup 0.6.4 and earlier allows remote attackers to view arbitrary files via .. (dot dot) sequences in an @@ command in an HTTP GET request.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q7mf-hp9m-cx6f
- Revision 1 · created ·
Published from osv record GHSA-q7mf-hp9m-cx6f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2004-1444 Advisory: Roundup Directory traversal vulnerability IDs: CVE-2004-1444, GHSA-q7mf-hp9m-cx6f Record: https://patchnext.com/advisories/cve-2004-1444 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: roundup 0.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI roundup: affected <= 0.6.4; fixed in 0.7.3 ## Suggested inspection (read-only) - `python -m pip show roundup`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on roundup. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q7mf-hp9m-cx6f (OSV record GHSA-q7mf-hp9m-cx6f lists affected ranges: PyPI roundup >=0 <0.7.3 (fixed)) - Verified: https://github.com/advisories/GHSA-q7mf-hp9m-cx6f (GitHub-reviewed advisory GHSA-q7mf-hp9m-cx6f lists affected ranges: PyPI roundup >=0 <=0.6.4) Commands are suggestions: review each one before running it.
Loading voting…