Jakarta Tomcat Denial of Service vulnerability
CVE-2003-0045GHSA-w97x-xfxf-f9xj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 3.3.1a), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat
- Affected
- < 3.3.1a
- Fixed in
- 3.3.1a
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w97x-xfxf-f9xj lists affected ranges: Maven org.apache.tomcat:tomcat >=0 <3.3.1a
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2003-0045: 2.49% estimated exploitation activity in the next 30 days; percentile 84.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jakarta Tomcat before 3.3.1a on certain Windows systems may allow remote attackers to cause a denial of service (thread hang and resource consumption) via a request for a JSP page containing an MS-DOS device name, such as aux.jsp.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w97x-xfxf-f9xj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2003-0045 Advisory: Jakarta Tomcat Denial of Service vulnerability IDs: CVE-2003-0045, GHSA-w97x-xfxf-f9xj Record: https://patchnext.com/advisories/cve-2003-0045 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 3.3.1a. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat: affected < 3.3.1a; fixed in 3.3.1a ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w97x-xfxf-f9xj (GitHub-reviewed advisory GHSA-w97x-xfxf-f9xj lists affected ranges: Maven org.apache.tomcat:tomcat >=0 <3.3.1a) Commands are suggestions: review each one before running it.
Loading voting…